[PATCH] D34393: [MC] Adding code padding for performance stability - infrastructure. NFC.

Omer Paparo Bivas via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Oct 16 01:52:20 PDT 2017


opaparo updated this revision to Diff 119116.
opaparo added a comment.

1. MCAsmBackend c'tor now takes a unique_ptr of MCCodePadder instead of a raw pointer
2. MCCodePaddingContext has a new field: IsBasicBlockReachableViaBranch
3. Changed names of a function and several variables




https://reviews.llvm.org/D34393

Files:
  include/llvm/CodeGen/AsmPrinter.h
  include/llvm/MC/MCAsmBackend.h
  include/llvm/MC/MCAssembler.h
  include/llvm/MC/MCCodePadder.h
  include/llvm/MC/MCFragment.h
  include/llvm/MC/MCObjectStreamer.h
  include/llvm/MC/MCStreamer.h
  include\llvm\MC\MCCodePadder.h
  lib/CodeGen/AsmPrinter/AsmPrinter.cpp
  lib/MC/CMakeLists.txt
  lib/MC/MCAsmBackend.cpp
  lib/MC/MCAssembler.cpp
  lib/MC/MCCodePadder.cpp
  lib/MC/MCFragment.cpp
  lib/MC/MCObjectStreamer.cpp
  lib/Target/Mips/MipsAsmPrinter.cpp
  lib/Target/X86/X86AsmPrinter.h
  lib\MC\MCCodePadder.cpp
  test/CodeGen/AArch64/arm64-opt-remarks-lazy-bfi.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D34393.119116.patch
Type: text/x-patch
Size: 50004 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20171016/2f606327/attachment.bin>


More information about the llvm-commits mailing list