[PATCH] D37771: llvm-dwarfdump: automatically dump both regular and .dwo variant of sections
Paul Robinson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Sep 13 14:36:46 PDT 2017
probinson added inline comments.
================
Comment at: lib/DebugInfo/DWARF/DWARFContext.cpp:243
+ bool ExplicitDWO =
+ Explicit && sys::path::extension(DObj->getFileName()) == ".dwo";
+ auto shouldDumpDWO = [&](unsigned DIDT_Section, StringRef Section) {
----------------
Hmmm now you are attaching a semantic significance to what is just a naming convention. I don't think that's appropriate.
We should not worry about what "kind" of file it is, just whether the sections exist or not.
https://reviews.llvm.org/D37771
More information about the llvm-commits
mailing list