[PATCH] D29798: [AMDGPU] Override PSet for M0
Matt Arsenault via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Feb 9 17:26:59 PST 2017
arsenm accepted this revision.
arsenm added a comment.
This revision is now accepted and ready to land.
LGTM with param name fixed
================
Comment at: lib/Target/AMDGPU/SIRegisterInfo.cpp:1333
+
+const int *SIRegisterInfo::getRegUnitPressureSets(unsigned RegUnit) const {
+ static const int Empty[] = { -1 };
----------------
Ditto
================
Comment at: lib/Target/AMDGPU/SIRegisterInfo.h:214
+ const int *getRegUnitPressureSets(unsigned RegUnit) const override;
+
----------------
Param name is misleading, it should be Reg not RegUnit
Repository:
rL LLVM
https://reviews.llvm.org/D29798
More information about the llvm-commits
mailing list