[PATCH] D27293: [WIP] Cleanup SplitCSR implementation
Matthias Braun via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Nov 30 20:55:02 PST 2016
MatzeB added a comment.
I think `getMinimalPhysRegClass()` may be more restrictive than necessary (I imagine you can end up the class for A B C D as the smallest class on X86 while the full GPR class would be more suitable on X86). I don't think we have a better generic notion today, so all that is left is to enumerate register classes that allow suitable spilling and cheaply copying between the registers inside the class.
There is also some bad code duplication going on here today. I think we solve the same (or really similar) problem in `LowerFormalArguments()` and `LowerReturn()`.
https://reviews.llvm.org/D27293
More information about the llvm-commits
mailing list