[PATCH] D26063: [ThinLTO] Use NoPromote flag in summary during promotion
Teresa Johnson via llvm-commits
llvm-commits at lists.llvm.org
Fri Oct 28 05:52:24 PDT 2016
tejohnson marked 2 inline comments as done.
tejohnson added inline comments.
================
Comment at: lib/Transforms/Utils/FunctionImportUtils.cpp:206
} else
- GV.setLinkage(getLinkage(&GV));
+ GV.setLinkage(getLinkage(&GV, DoPromote));
----------------
mehdi_amini wrote:
> The flow to initialize the "DoPromote" is very difficult to process / follow here. We should seek some refactoring to make it more readable.
I passed in false here directly, since DoPromote would always be false and that will hopefully be clearer.
https://reviews.llvm.org/D26063
More information about the llvm-commits
mailing list