[PATCH] D25412: Move the global variables representing each Target behind accessor function
Mehdi AMINI via llvm-commits
llvm-commits at lists.llvm.org
Sun Oct 9 16:09:25 PDT 2016
mehdi_amini marked an inline comment as done.
mehdi_amini added a comment.
Thanks Justin!
================
Comment at: lib/Target/AVR/TargetInfo/AVRTargetInfo.cpp:14
+Target &getTheAVRTarget() {
+ static Target getTheAVRTarget;
+ return getTheAVRTarget;
----------------
jlebar wrote:
> Probably should be called TheAVRTarget?
Sure, did the change before committing.
https://reviews.llvm.org/D25412
More information about the llvm-commits
mailing list