[PATCH] D25412: Move the global variables representing each Target behind accessor function
Justin Lebar via llvm-commits
llvm-commits at lists.llvm.org
Sun Oct 9 16:07:50 PDT 2016
jlebar accepted this revision.
jlebar added a reviewer: jlebar.
jlebar added inline comments.
This revision is now accepted and ready to land.
================
Comment at: lib/Target/AVR/TargetInfo/AVRTargetInfo.cpp:14
+Target &getTheAVRTarget() {
+ static Target getTheAVRTarget;
+ return getTheAVRTarget;
----------------
Probably should be called TheAVRTarget?
https://reviews.llvm.org/D25412
More information about the llvm-commits
mailing list