[PATCH] D17872: [NVPTX] Add a truncate DAG node to some calls.

Justin Lebar via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 31 18:10:11 PDT 2016


jlebar marked an inline comment as done.

================
Comment at: lib/Target/NVPTX/NVPTXISelLowering.cpp:1621
@@ -1620,3 +1620,3 @@
       for (unsigned i = 0, e = Ins.size(); i != e; ++i) {
         unsigned sz = VTs[i].getSizeInBits();
         unsigned AlignI = GreatestCommonDivisor64(RetAlign, Offsets[i]);
----------------
jlebar wrote:
> jingyue wrote:
> > Maybe call it BitWidth instead? 
> I'll fix that and the variable capitalization here in a separate change, which I'll land right after this one.
Actually, I take it back.  The whole file is actually pretty consistent with "sz" and lower-case "align".  The LLVM style guide says to be consistent and to avoid big refactorings unless you're touching all the code anyway.  I think we should probably leave this sleeping dragon un-tickled for now.


http://reviews.llvm.org/D17872





More information about the llvm-commits mailing list