[PATCH] D15765: Rename OutputSection -> Segment.

Rafael EspĂ­ndola via llvm-commits llvm-commits at lists.llvm.org
Wed Dec 23 19:11:50 PST 2015


Unfortunately I don't think that is correct. The spec says

---------------------------------------------------------------------------------------
In the first phase, input sections that match in name, type and
attribute flags should be concatenated into single sections ...

In the second phase, sections should be assigned to segments or other
units based on their attribute flags ...
--------------------------------------------------------------------------------------------

So our OutputSection is what the "single sections" refers to.


On 23 December 2015 at 21:07, Rui Ueyama <ruiu at google.com> wrote:
> ruiu created this revision.
> ruiu added a reviewer: rafael.
> ruiu added a subscriber: llvm-commits.
>
> Segment is the official terminology in the ELF spec to denote
> the output section. Segment is better than OutputSection since
> it is shorter and less confusing than InputSection.
>
> http://reviews.llvm.org/D15765
>
> Files:
>   ELF/CMakeLists.txt
>   ELF/Config.h
>   ELF/InputSection.cpp
>   ELF/InputSection.h
>   ELF/LinkerScript.cpp
>   ELF/MarkLive.cpp
>   ELF/OutputSections.cpp
>   ELF/OutputSections.h
>   ELF/Segments.cpp
>   ELF/Segments.h
>   ELF/SymbolTable.cpp
>   ELF/SymbolTable.h
>   ELF/Symbols.cpp
>   ELF/Symbols.h
>   ELF/Target.cpp
>   ELF/Writer.cpp
>


More information about the llvm-commits mailing list