[PATCH] D15765: Rename OutputSection -> Segment.
Rui Ueyama via llvm-commits
llvm-commits at lists.llvm.org
Wed Dec 23 18:07:07 PST 2015
ruiu created this revision.
ruiu added a reviewer: rafael.
ruiu added a subscriber: llvm-commits.
Segment is the official terminology in the ELF spec to denote
the output section. Segment is better than OutputSection since
it is shorter and less confusing than InputSection.
http://reviews.llvm.org/D15765
Files:
ELF/CMakeLists.txt
ELF/Config.h
ELF/InputSection.cpp
ELF/InputSection.h
ELF/LinkerScript.cpp
ELF/MarkLive.cpp
ELF/OutputSections.cpp
ELF/OutputSections.h
ELF/Segments.cpp
ELF/Segments.h
ELF/SymbolTable.cpp
ELF/SymbolTable.h
ELF/Symbols.cpp
ELF/Symbols.h
ELF/Target.cpp
ELF/Writer.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D15765.43574.patch
Type: text/x-patch
Size: 54801 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20151224/8ccbc8c8/attachment.bin>
More information about the llvm-commits
mailing list