[PATCH] D15483: [Polly] Unique value write accesses
Tobias Grosser via llvm-commits
llvm-commits at lists.llvm.org
Wed Dec 16 08:43:28 PST 2015
grosser added a comment.
One more comment:
================
Comment at: lib/Analysis/ScopInfo.cpp:3933
@@ +3932,3 @@
+
+void ScopInfo::ensureValueStore(Instruction *Value) {
+ ScopStmt *Stmt = scop->getStmtForBasicBlock(Value->getParent());
----------------
I would prefer the name 'ensureValueWrite' as this corresponds better with the WRITE/READ naming scheme used in the surrounding code.
http://reviews.llvm.org/D15483
More information about the llvm-commits
mailing list