[PATCH] [LLD] Add a new PE/COFF port

Rui Ueyama ruiu at google.com
Thu May 28 11:46:48 PDT 2015


On Thu, May 28, 2015 at 11:28 AM, Rafael EspĂ­ndola <
rafael.espindola at gmail.com> wrote:

> >> bool hasData() const { return HasData; }
> >
> >
> > By doing that we can get rid of "virtual" from the function, but I think
> it
> > slightly decreases readability of the thing. Now you have to define a new
> > constructor to initialize HasData right?
>
> Yes, the various derived constructors would set it. It is a somewhat
> common pattern in llvm, but usually in cases with far more fields than
> this.
>

I'll probably have to do that (and inlining small accessors defined in
Chunks.cpp too) when I want to squeeze out the last cycles. At this moment
I'd prefer keeping it dumb and simple.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20150528/060f09ff/attachment.html>


More information about the llvm-commits mailing list