<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On Thu, May 28, 2015 at 11:28 AM, Rafael EspĂ­ndola <span dir="ltr"><<a href="mailto:rafael.espindola@gmail.com" target="_blank">rafael.espindola@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><span class="">>> bool hasData() const { return HasData; }<br>
><br>
><br>
> By doing that we can get rid of "virtual" from the function, but I think it<br>
> slightly decreases readability of the thing. Now you have to define a new<br>
> constructor to initialize HasData right?<br>
<br>
</span>Yes, the various derived constructors would set it. It is a somewhat<br>
common pattern in llvm, but usually in cases with far more fields than<br>
this.<br></blockquote><div><br></div><div>I'll probably have to do that (and inlining small accessors defined in Chunks.cpp too) when I want to squeeze out the last cycles. At this moment I'd prefer keeping it dumb and simple.</div></div></div></div>