[PATCH] [mips] [IAS] Rename MipsAssemblerOptions::getATRegNum to getATReg. NFC.

Daniel Sanders daniel.sanders at imgtec.com
Tue Mar 24 04:11:34 PDT 2015


I agree with the principle that the set/get functions should have the same names. I think we ought to make it clear that it's an index though. Maybe, [gs]etATRegIndex()?


================
Comment at: lib/Target/Mips/AsmParser/MipsAsmParser.cpp:2212
@@ -2211,3 +2211,3 @@
   if ((RegIndex != 0) && 
-      ((int)AssemblerOptions.back()->getATRegNum() == RegIndex)) {
     if (RegIndex == 1)
----------------
Are you going to eliminate the casts in a follow up?

http://reviews.llvm.org/D8480

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the llvm-commits mailing list