[PATCH] Using Masked Load / Store intrinsics in Loop Vectorizer

Nadav Rotem nrotem at apple.com
Mon Dec 8 08:50:11 PST 2014


+  /// Returns true if vector representation of the instruction \p I
+  /// requires mask.
+  bool toBuildMaskedVectorInst(const Instruction* I) {
+    return (MaskedOp.count(I) != 0);
+  }
+  void SI();

Maybe a better name would be "isMaskRequired"?

http://reviews.llvm.org/D6527






More information about the llvm-commits mailing list