[PATCH] Using Masked Load / Store intrinsics in Loop Vectorizer

Nadav Rotem nrotem at apple.com
Mon Dec 8 08:50:09 PST 2014


+  /// Returns true if vector representation of the instruction \p I
+  /// requires mask.
+  bool toBuildMaskedVectorInst(const Instruction* I) {
+    return (MaskedOp.count(I) != 0);
+  }
+  void SI();

Maybe a better name would be "isMaskRequired"? 


> On Dec 7, 2014, at 5:23 AM, Elena Demikhovsky <elena.demikhovsky at intel.com> wrote:
> 
> Thank you all for reviewing this. I addressed all comments and applying the updated patch.
> 
> http://reviews.llvm.org/D6527
> 
> Files:
>  include/llvm/Analysis/TargetTransformInfo.h
>  lib/Analysis/TargetTransformInfo.cpp
>  lib/Target/X86/X86TargetTransformInfo.cpp
>  lib/Transforms/Vectorize/LoopVectorize.cpp
>  test/Transforms/LoopVectorize/X86/masked_load_store.ll
> <D6527.17024.patch>





More information about the llvm-commits mailing list