[PATCH] Prevent the creation of empty location list ranges.

Frederic Riss friss at apple.com
Wed Dec 3 18:30:26 PST 2014


  - Implement SeenInstructionInRange as a forward_list to guarantee element pointer stability.
  - Add more in depth comment.
  - Rename validateOpenRanges to markOpenRangesNonEmpty.

http://reviews.llvm.org/D6497

Files:
  lib/CodeGen/AsmPrinter/DbgValueHistoryCalculator.cpp
  lib/CodeGen/AsmPrinter/DbgValueHistoryCalculator.h
  test/DebugInfo/X86/block-capture.ll
  test/DebugInfo/X86/dbg-value-inlined-parameter.ll
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D6497.16905.patch
Type: text/x-patch
Size: 6000 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20141204/10ec8c50/attachment.bin>


More information about the llvm-commits mailing list