[PATCH] [AArch64] FP load balancing pass for Cortex-A57
James Molloy
james at jamesmolloy.co.uk
Fri Aug 8 05:43:17 PDT 2014
Thanks Tim,
Using unique_ptr ended up making the code harder to read, so I simply added
a deletion loop which I think is cleaner.
Committed in r215199, thankyou to all reviewers!
Cheers,
James
On 8 August 2014 10:42, Tim Northover <t.p.northover at gmail.com> wrote:
> Just added llvm-commits.
>
> ================
> Comment at: lib/Target/AArch64/AArch64A57FPLoadBalancing.cpp:318
> @@ +317,3 @@
> + // "link" register between each inst in the chain.
> + std::map<unsigned, Chain*> ActiveChains;
> + std::set<Chain*> AllChains;
> ----------------
> Tim Northover wrote:
> > Aren't these chains leaked? It *looks* like you could make this (or the
> set) a unique_ptr<Chain>.
> Also, this should definitely be the set. I hadn't noticed things get
> removed from ActiveChains when I wrote this. Should have been obvious, in
> retrospect.
>
> http://reviews.llvm.org/D4791
>
>
>
> _______________________________________________
> llvm-commits mailing list
> llvm-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20140808/93fedb67/attachment.html>
More information about the llvm-commits
mailing list