[PATCH] [lld] add calls to nativereader/nativewriter
Shankar Kalpathi Easwaran
shankarke at gmail.com
Wed Oct 16 14:00:37 PDT 2013
================
Comment at: lib/Driver/Driver.cpp:143
@@ +142,3 @@
+ resultFile = nativeFile[0].get();
+#endif
+
----------------
kledzik at apple.com wrote:
> Shankar Kalpathi Easwaran wrote:
> > Rui Ueyama wrote:
> > > This should be a separate function for readability.
> > Ok.
> I wonder if it could be made into a Pass. There could also be a pass to write to yaml and read it back too. Then we just need to figure out how to make sure those passes are run in the test suite.
Agree. I will do this.
I will create two passes
DumpIRPass, DumpYAMLPass
The passes would be enabled at all times in DEBUG mode, so that functionalities are not regressed.
http://llvm-reviews.chandlerc.com/D1955
More information about the llvm-commits
mailing list