[llvm] r184217 - Add a GetUniqueID that will replace the uniqueID of PathV1.h.

Sean Silva silvas at purdue.edu
Wed Jun 19 12:54:34 PDT 2013


On Wed, Jun 19, 2013 at 11:59 AM, Rafael EspĂ­ndola <
rafael.espindola at gmail.com> wrote:

> On 19 June 2013 13:46, Sean Silva <silvas at purdue.edu> wrote:
> > What is up with the naming of this function? Isn't the naming convention
> for
> > the surrounding sys::fs code like_this instead of LikeThis?
> > Sorry for the late review.
>
> Good question. I am really uncertain about what the best name style
> is. The guideline in
>
> http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly
> is that only STL like classes should have methods_named_like_this, but
> quiet a bit of the new path, file system and a bit Object have names
> like that :-(
>

Regardless, as a function, shouldn't it at least be `getUniqueID` by our
conventions (functions start with lowercase)? I think that the snake_case
is because the library is modeled after one of the boost libs (which IIRC
is slated for inclusion in C++14).

-- Sean Silva
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20130619/bc4454c3/attachment.html>


More information about the llvm-commits mailing list