[lld] r183887 - [PECOFF] Make readSymbolTable a const function.

Rui Ueyama ruiu at google.com
Wed Jun 12 22:39:02 PDT 2013


On Wed, Jun 12, 2013 at 10:32 PM, Shankar Easwaran
<shankare at codeaurora.org>wrote:

> On 6/13/2013 12:23 AM, Rui Ueyama wrote:
>
>>        }
>> @@ -384,7 +385,7 @@ private:
>>     atom_collection_vector<**UndefinedAtom>     UndefinedAtoms;
>>     atom_collection_vector<**SharedLibraryAtom> SharedLibraryAtoms;
>>     atom_collection_vector<**AbsoluteAtom> AbsoluteAtoms;
>> -  llvm::BumpPtrAllocator AtomStorage;
>> +  mutable llvm::BumpPtrAllocator AtomStorage;
>>     const TargetInfo &_targetInfo;
>>
> Inconsistent naming of member variables, lld uses _ and the first letter
> lowercase.
>

Right. I wanted to rename them too. I will do that at some point.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20130612/2b616f84/attachment.html>


More information about the llvm-commits mailing list