[lld] r183887 - [PECOFF] Make readSymbolTable a const function.

Shankar Easwaran shankare at codeaurora.org
Wed Jun 12 22:32:59 PDT 2013


On 6/13/2013 12:23 AM, Rui Ueyama wrote:
>        }
> @@ -384,7 +385,7 @@ private:
>     atom_collection_vector<UndefinedAtom>     UndefinedAtoms;
>     atom_collection_vector<SharedLibraryAtom> SharedLibraryAtoms;
>     atom_collection_vector<AbsoluteAtom> AbsoluteAtoms;
> -  llvm::BumpPtrAllocator AtomStorage;
> +  mutable llvm::BumpPtrAllocator AtomStorage;
>     const TargetInfo &_targetInfo;
Inconsistent naming of member variables, lld uses _ and the first letter 
lowercase.

Thanks

Shankar Easwaran

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, hosted by the Linux Foundation




More information about the llvm-commits mailing list