[PATCH] Allow users to choose identity used to sign tools.
Charles Davis
cdavis5x at gmail.com
Fri Apr 5 18:05:06 PDT 2013
================
Comment at: Makefile.rules:1518
@@ -1517,1 +1517,3 @@
ifdef CODESIGN_TOOLS
+CODESIGN_IDENTITY ?= -
+
----------------
I'd call it `TOOL_CODESIGN_IDENTITY`; that way it's more consistent with the other `make(1)` variables that affect how tools get built.
================
Comment at: Makefile.rules:1528
@@ -1526,1 +1527,3 @@
+ with identity $(CODESIGN_IDENTITY)
+ $(Verb) codesign --sign $(CODESIGN_IDENTITY) $@
else
----------------
Why the long form option? I don't see any particular advantage to it, considering that most people build with verbose makefile output off.
================
Comment at: Makefile.rules:1526-1527
@@ -1523,3 +1525,4 @@
$(StripWarnMsg)
- $(Echo) ======= Code-Signing $(BuildMode) Executable $(TOOLNAME)
- $(Verb) codesign -s - $@
+ $(Echo) ======= Code-Signing $(BuildMode) Executable $(TOOLNAME) \
+ with identity $(CODESIGN_IDENTITY)
+ $(Verb) codesign --sign $(CODESIGN_IDENTITY) $@
----------------
Is this really necessary? I know it's useful for debugging the Makefiles, but if someone really needs to do that, they'll usually just turn on verbose output (where it will show up anyway) so they can see what went wrong.
http://llvm-reviews.chandlerc.com/D632
More information about the llvm-commits
mailing list