[llvm-commits] Adding a builder for ExecutionEngines

Evan Cheng evan.cheng at apple.com
Thu Jul 16 13:11:14 PDT 2009


On Jul 14, 2009, at 11:05 AM, Reid Kleckner wrote:

> On Mon, Jul 13, 2009 at 10:15 PM, Evan Cheng<evan.cheng at apple.com>  
> wrote:
>> Thanks Reid. Sorry about the late review. I just have a few nitpicks
>> in addition to what Jeffrey has pointed out.
>>
>> + public:
>> +  enum EnginePreference {
>> +    EITHER,
>> +    INTERP,
>> +    JITONLY
>> +  };
>>
>> LLVM is a polite compiler. We don't do all-caps. :-) How about
>> InterpOnly, JITOnly as bitmasks? Then "EITHER" would just be the two
>> or'red together?
>
> Sure, I also put then in a namespace similar to CodeGenOpt and friends
> so I could drop the ENG_ prefix.
>
>> +  /// init - Does the common initialization of default options.
>> +  ///
>> +  void init() {
>>
>> I prefer a more explicit name. Perhaps InitEngine()?
>
> Done.
>
>> Thanks,
>>
>> Evan
>
> If that's all I'll ask Jeff to commit it.

Please do. Or you can ask Chris for commit access. Thanks.

Evan

>
> Thanks,
> Reid
> < 
> EngineBuilderPatch.diff 
> >_______________________________________________
> llvm-commits mailing list
> llvm-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits




More information about the llvm-commits mailing list