[llvm-commits] Adding a builder for ExecutionEngines
Reid Kleckner
rnk at mit.edu
Tue Jul 14 11:05:48 PDT 2009
On Mon, Jul 13, 2009 at 10:15 PM, Evan Cheng<evan.cheng at apple.com> wrote:
> Thanks Reid. Sorry about the late review. I just have a few nitpicks
> in addition to what Jeffrey has pointed out.
>
> + public:
> + enum EnginePreference {
> + EITHER,
> + INTERP,
> + JITONLY
> + };
>
> LLVM is a polite compiler. We don't do all-caps. :-) How about
> InterpOnly, JITOnly as bitmasks? Then "EITHER" would just be the two
> or'red together?
Sure, I also put then in a namespace similar to CodeGenOpt and friends
so I could drop the ENG_ prefix.
> + /// init - Does the common initialization of default options.
> + ///
> + void init() {
>
> I prefer a more explicit name. Perhaps InitEngine()?
Done.
> Thanks,
>
> Evan
If that's all I'll ask Jeff to commit it.
Thanks,
Reid
-------------- next part --------------
A non-text attachment was scrubbed...
Name: EngineBuilderPatch.diff
Type: text/x-diff
Size: 29222 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20090714/2673888a/attachment.diff>
More information about the llvm-commits
mailing list