[lldb-dev] error: process launch failed: Lost debug server connection

NeckTwi via lldb-dev lldb-dev at lists.llvm.org
Thu Jul 12 07:49:59 PDT 2018

I’m getting same error even if I debug on the same device.

necktwi at pi:/home/necktwi/Workspace/RemoteDebugTest/build$ lldb-server-6.0 platform --listen "*:1234" --server
Connection established.

necktwi at pi:/home/necktwi/Workspace/RemoteDebugTest/build$ lldb-6.0 
(lldb) platform select remote-linux
  Platform: remote-linux
 Connected: no
(lldb) platform connect connect://localhost:1234
  Platform: remote-linux
OS Version: 4.9.78 (4.9.78-v7+)
    Kernel: #1084 SMP Thu Jan 25 18:05:49 GMT 2018
  Hostname: pi.RemoteDebugTest.com
 Connected: yes
WorkingDir: /home/necktwi/Workspace/RemoteDebugTest/build
(lldb) file RemoteDebugTest
Current executable set to 'RemoteDebugTest' (arm).
(lldb) run
error: process launch failed: Lost debug server connection

I think it’s a bug. I tried to sign up for bugs-admin at lists.llvm.org <mailto:bugs-admin at lists.llvm.org> but I didn’t get a reply though I’ve put a mail with my email-id and name.

… NeckTwi

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-dev/attachments/20180712/bb2e084f/attachment.html>

More information about the lldb-dev mailing list