[lldb-dev] Compiler types and renamings

Bruce Mitchener via lldb-dev lldb-dev at lists.llvm.org
Thu Sep 17 03:08:35 PDT 2015


Howdy!

I was looking at some of the CompilerType changes and had some questions
related to the recent cleanups and renamings.


   - clang_type_t is a typedef for void* and is used for the opaque qual
   type code among other things. However, the m_type on CompilerType is just a
   void*.  Should we rename clang_type_t to compiler_type_t or just do away
   with it and use void* instead?
   - SymbolFileDWARF has 2 typedefs, DIEToClangType and ClangTypeToDIE
   which are used for 2 maps, m_forward_decl_die_to_clang_type
   and m_forward_decl_clang_type_to_die. Should these be renamed to use
   Compiler instead of Clang?
   - Any use of an instance of CompilerType in general code (code not in a
   file with Clang in the name) can probably be renamed from clang_type to
   compiler_type, right? This would include the clang_type member on Type.

I'd like to do any of the above, just want to make sure that it won't clash
with pending changes like this and that people actually want this to happen.

 - Bruce
   Part time code janitor
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-dev/attachments/20150917/5cf33fa5/attachment.html>


More information about the lldb-dev mailing list