[lldb-dev] Hello, I have Questions, about lldb:(

Malea, Daniel daniel.malea at intel.com
Sun Oct 14 10:21:37 PDT 2012

The instructions posted on the build page are slightly out-of-date. LLDB trunk builds against LLVM and Clang trunk, and not a pinned revision as the docs mention. If you're using older revisions, you should update all your working copies to trunk.

The error you're seeing with importing _lldb is due to a problem in one of the Makefiles. Python requires an _lldb.so symlink (pointing to liblldb.so) on the PYTHONPATH in order for the import to work correctly. I am working on a cross-platform way to generate it with the Makefiles, but until it is ready, try the following workaround (creating the symlink manually):

$ ln -sf <absolute-path-to-build-dir>/Debug+Asserts/lib/liblldb.so <build-dir>/Debug+Asserts/lib/python/lldb/python2.7+/_lldb.so

Then, if your PYTHONPATH is set to "<build-dir>/Debug+Asserts/lib/python/lldb/python2.7+", you should be able to run:

$ python -c 'import lldb'

with no errors.

Best of luck,

From: lldb-dev-bounces at cs.uiuc.edu [mailto:lldb-dev-bounces at cs.uiuc.edu] On Behalf Of Kyung su Kim
Sent: Saturday, October 13, 2012 6:20 PM
To: lldb-dev at cs.uiuc.edu
Subject: [lldb-dev] Hello, I have Questions, about lldb:(


I'm a university student in korea

I have a project in my school, that related dissembleing arm machine code

( I'll use python script language to my project)

so I found this llvm project and i tried to build llvm

but I faced some problems..

(my compilation enviroment is Ubuntu Linux 10.x )

I saw http://lldb.llvm.org/build.html , and worked step by step

first problem is that the llvm_revision doesn't update,..

typed as I saw in manual "svn update -r 127682" ,doesn't work properly..

the result is as below..

root at kaspyx:~/llvm/tools# grep -m 1 llvm_revision lldb/scripts/build-llvm.pl<http://build-llvm.pl>
our $llvm_revision = "127600";

it looks some guess.. but i wonder why llvm_revision version doesn't update is..

why the revision is 127600?? i want update to 127682..

it's my guess...

most of all, lldb doesn't work..

i compiled llvm, lldb, clang... step by step, referenced manual..

but lldb.py doesn't work..

There are compiled binaries in my directory.. ( like "lldb", "lldb.py" ..etc)

but When I typed for using lldb python library, I saw error strings


root at kaspyx:~/build2/Debug+Asserts/bin# python lldb.py

Traceback (most recent call last):
  File "lldb.py", line 25, in <module>
    _lldb = swig_import_helper()
  File "lldb.py", line 17, in swig_import_helper
    import _lldb
ImportError: No module named _lldb


I couldn't find _lldb module.. ,

problems are looks relate llvm_revision.

I don't know what should i do..

am i compiled properly??

thanks ....

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-dev/attachments/20121014/51b438d1/attachment.html>

More information about the lldb-dev mailing list