[lldb-dev] Hello, I have Questions, about lldb:(

Kyung su Kim kaspyx at gmail.com
Sat Oct 13 15:20:05 PDT 2012


I'm a university student in korea

I have a project in my school, that related dissembleing arm machine code

( I'll use python script language to my project)

so I found this llvm project and i tried to build llvm

but I faced some problems..

(my compilation enviroment is Ubuntu Linux 10.x )

I saw http://lldb.llvm.org/build.html , and worked step by step

first problem is that the llvm_revision doesn't update,..

typed as I saw in manual "svn update -r 127682" ,doesn't work properly..

the result is as below..

root at kaspyx:~/llvm/tools# grep -m 1 llvm_revision lldb/scripts/build-llvm.pl
our $llvm_revision = "127600";

it looks some guess.. but i wonder why llvm_revision version doesn't update

why the revision is 127600?? i want update to 127682..

it's my guess...

most of all, lldb doesn't work..

i compiled llvm, lldb, clang... step by step, referenced manual..

but lldb.py doesn't work..

There are compiled binaries in my directory.. ( like "lldb", "lldb.py"

but When I typed for using lldb python library, I saw error strings


root at kaspyx:~/build2/Debug+Asserts/bin# python lldb.py

Traceback (most recent call last):
  File "lldb.py", line 25, in <module>
    _lldb = swig_import_helper()
  File "lldb.py", line 17, in swig_import_helper
    import _lldb
ImportError: No module named _lldb


I couldn't find _lldb module.. ,

problems are looks relate llvm_revision.

I don't know what should i do..

am i compiled properly??

thanks ....
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-dev/attachments/20121014/02ca15ab/attachment.html>

More information about the lldb-dev mailing list