[Lldb-commits] [PATCH] D156687: [lldb][AArch64] Add kind marker to ReadAll/WriteALLRegisterValues data
Muhammad Omair Javaid via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Fri Sep 1 04:05:16 PDT 2023
omjavaid added inline comments.
================
Comment at: lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.cpp:573
- ::memcpy(dst, GetGPRBuffer(), GetGPRBufferSize());
- dst += GetGPRBufferSize();
+ dst = AddSavedRegisters(dst, SavedRegistersKind::GPR, GetGPRBuffer(),
+ GetGPRBufferSize());
----------------
I think we have lost some of code readability of ReadAllRegisterValues function by introducing AddSavedRegisters mechanism. It does remove some duplication of memcpy but it also introduces some differentiation between Read/WritellRegisterValues functions. I am inclined that we should put the memcpy into ReadAllRegisterValues to make it look similar to its Write counterpart.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D156687/new/
https://reviews.llvm.org/D156687
More information about the lldb-commits
mailing list