[Lldb-commits] [PATCH] D145955: Refactor ObjectFilePlaceholder for sharing

jeffrey tan via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Mar 13 09:47:19 PDT 2023


yinghuitan created this revision.
yinghuitan added reviewers: clayborg, labath, jingham, jdoerfert, JDevlieghere, kusmour, GeorgeHuyubo.
Herald added a project: All.
yinghuitan requested review of this revision.
Herald added a project: LLDB.
Herald added a subscriber: lldb-commits.

This patch refactors PlaceholderObjectFile into ObjectFile plugin directory
so that we can reuse it for other cases like coredump debugging with NT_FILE
notes.

PlaceholderObjectFile is also renamed to ObjectFilePlaceholder to be consistent
with ObjectFile plugin naming convention.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D145955

Files:
  lldb/source/Plugins/ObjectFile/CMakeLists.txt
  lldb/source/Plugins/ObjectFile/Placeholder/CMakeLists.txt
  lldb/source/Plugins/ObjectFile/Placeholder/ObjectFilePlaceholder.cpp
  lldb/source/Plugins/ObjectFile/Placeholder/ObjectFilePlaceholder.h
  lldb/source/Plugins/Process/minidump/CMakeLists.txt
  lldb/source/Plugins/Process/minidump/ProcessMinidump.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D145955.504719.patch
Type: text/x-patch
Size: 12266 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20230313/c8ffe296/attachment-0001.bin>


More information about the lldb-commits mailing list