[Lldb-commits] [PATCH] D132395: [lldb] [gdb-remote] Use Communication::WriteAll() over Write()

Pavel Labath via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Sep 5 08:08:01 PDT 2022


labath added a comment.

In D132395#3745227 <https://reviews.llvm.org/D132395#3745227>, @mgorny wrote:

> Yeah, I meant inside LLDB, since that's what we're talking about. Basically, I'm wondering if we should perhaps rename `WriteAll()` to `Write()`, remove the old `Write()` method and just use the looped variant everywhere (implying also via `SB*`).

Ok. In that case, I generally agree with you, but I am worried about consistency, not just with other Write methods, but also with all Read-like methods, and I'm not convinced that renaming just a single class will do more good than harm. But I would support a wider refactor of Read/Write like calls which makes it more obvious whether a particular call is able to complete with partial data.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D132395/new/

https://reviews.llvm.org/D132395



More information about the lldb-commits mailing list