[Lldb-commits] [PATCH] D128292: [lldb/Fuzzer] Add command interpreter fuzzer for LLDB

Med Ismail Bennani via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Jun 21 13:44:49 PDT 2022


mib added inline comments.


================
Comment at: lldb/tools/lldb-fuzzer/lldb-commandinterpreter-fuzzer/lldb-commandinterpreter-fuzzer.cpp:39
+  SBCommandReturnObject ro = SBCommandReturnObject();
+  SBCommandInterpreter thisinterpreter = debugger.GetCommandInterpreter();
+
----------------
cassanova wrote:
> mib wrote:
> > mib wrote:
> > > Nit: the variable naming does really follow the lldb's style.
> > doesn't *
> Oh shoot, I didn't notice. Would `interpreter` or `ci` be a better variable name?
I was more annoyed by the fact that the variable started with `this`. It's a reserved keyword in C++ and that can it make error prone. However, `ci` is a great candidate for this :)


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D128292/new/

https://reviews.llvm.org/D128292



More information about the lldb-commits mailing list