[Lldb-commits] [PATCH] D128292: [lldb/Fuzzer] Add command interpreter fuzzer for LLDB

Chelsea Cassanova via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Jun 21 13:41:44 PDT 2022


cassanova added inline comments.


================
Comment at: lldb/tools/lldb-fuzzer/lldb-commandinterpreter-fuzzer/CMakeLists.txt:15
+    liblldb
+    lldbFuzzerUtils
+    )
----------------
JDevlieghere wrote:
> I don't think this used any longer. 
Ok, I can remove this library.


================
Comment at: lldb/tools/lldb-fuzzer/lldb-commandinterpreter-fuzzer/lldb-commandinterpreter-fuzzer.cpp:17
+#include "lldb/API/SBTarget.h"
+#include "utils/TempFile.h"
+
----------------
JDevlieghere wrote:
> Not used?
Not in this file, but removing that include causes the compiler to not recognize the llvm and lldb_fuzzer namespaces. That's also fine in this file because neither of those namespaces are used but I still found it strange.


================
Comment at: lldb/tools/lldb-fuzzer/lldb-commandinterpreter-fuzzer/lldb-commandinterpreter-fuzzer.cpp:39
+  SBCommandReturnObject ro = SBCommandReturnObject();
+  SBCommandInterpreter thisinterpreter = debugger.GetCommandInterpreter();
+
----------------
mib wrote:
> mib wrote:
> > Nit: the variable naming does really follow the lldb's style.
> doesn't *
Oh shoot, I didn't notice. Would `interpreter` or `ci` be a better variable name?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D128292/new/

https://reviews.llvm.org/D128292



More information about the lldb-commits mailing list