[Lldb-commits] [PATCH] D113314: [lldb] Use std::string instead of llvm::Twine
Jonas Devlieghere via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Fri Nov 5 13:17:52 PDT 2021
JDevlieghere marked an inline comment as done.
JDevlieghere added a subscriber: david.
JDevlieghere added a comment.
@David: Yes, I considered it, but I think this is slightly more readable.
================
Comment at: lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationClient.cpp:1113
+ std::string packet =
+ "QEnableCompression:type:" + std::string(avail_name) + ";";
+ if (SendPacketAndWaitForResponse(packet, response) != PacketResult::Success)
----------------
mgorny wrote:
> I'd personally prefer `avail_name.str()` instead of explicit `std::string()` but that's just me.
Works for me. That actually makes it fit on a single line.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D113314/new/
https://reviews.llvm.org/D113314
More information about the lldb-commits
mailing list