[Lldb-commits] [PATCH] D111963: [lldb] [lldb-server] Refactor ConnectToRemote()
Michał Górny via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Sun Oct 17 07:11:26 PDT 2021
mgorny created this revision.
mgorny added reviewers: labath, krytarowski, emaste, teemperor.
mgorny requested review of this revision.
Refactor ConnectToRemote() to improve readability and make future
changes easier:
1. Replace static buffers with std::string.
2. When handling errors, prefer reporting the actual error over dumb 'connection status is not success'.
3. Move host/port parsing directly into reverse_connection condition that is its only user, and simplify it to make its purpose (verifying that a valid port is provided) clear.
https://reviews.llvm.org/D111963
Files:
lldb/tools/lldb-server/lldb-gdbserver.cpp
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D111963.380244.patch
Type: text/x-patch
Size: 4384 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20211017/92b818ed/attachment.bin>
More information about the lldb-commits
mailing list