[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names

Michał Górny via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Sun Sep 5 01:44:45 PDT 2021


mgorny updated this revision to Diff 370785.
mgorny added a comment.

Preserve the prior (probably accidental) behavior of generic names taking precedence over later registers with the same name (e.g. generic `sp` alias taking precedence over 16-bit `sp` pseudo-register).


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D108554/new/

https://reviews.llvm.org/D108554

Files:
  lldb/source/Host/common/NativeRegisterContext.cpp
  lldb/source/Target/RegisterContext.cpp
  lldb/test/API/functionalities/gdb_remote_client/TestGDBServerTargetXML.py

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D108554.370785.patch
Type: text/x-patch
Size: 5927 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20210905/4f41d49a/attachment.bin>


More information about the lldb-commits mailing list