[Lldb-commits] [PATCH] D72953: Fix the handling of unnamed bit-fields when parsing DWARF
Shafik Yaghmour via Phabricator via lldb-commits
lldb-commits at lists.llvm.org
Wed Jan 22 16:28:43 PST 2020
shafik updated this revision to Diff 239732.
shafik marked 14 inline comments as done.
shafik added a comment.
Realized that the assert that I was hitting in some cases only reproduced using C++ for example one case we needed to use a class w/ private members. So created a new bit-field test which is C++ specific.
Addressed comments:
- Removed magic numbers from `FieldInfo`
- Removed the need for `last_field_info` and `last_bitfield_info`
- Refactored away more code
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D72953/new/
https://reviews.llvm.org/D72953
Files:
lldb/packages/Python/lldbsuite/test/lang/cpp/bitfields/Makefile
lldb/packages/Python/lldbsuite/test/lang/cpp/bitfields/TestCppBitfields.py
lldb/packages/Python/lldbsuite/test/lang/cpp/bitfields/main.cpp
lldb/source/Plugins/SymbolFile/DWARF/DWARFASTParserClang.cpp
lldb/source/Plugins/SymbolFile/DWARF/DWARFASTParserClang.h
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D72953.239732.patch
Type: text/x-patch
Size: 19042 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20200123/871d11e4/attachment-0001.bin>
More information about the lldb-commits
mailing list