[Lldb-commits] [PATCH] D61779: FuncUnwinders: General clean up and optimization

Pavel Labath via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri May 10 01:36:05 PDT 2019


labath created this revision.
labath added reviewers: jasonmolenda, clayborg.

A large chunk of this file was dealing with the caching of unwind plans.
In this patch I create a helper class to encapsulate this behavior and
leave the functions to deal with the actual work, which is to compute
the actual plan.

Since the caching now is handled by a separate class, it is also
possible to optimize it better without hampering readability. The way I
achieve that is by using a special shared_ptr value to mean "not
initialized" which means we can avoid having a special bool flag for
that purpose. This results in a net decrease of the size of the
FuncUnwinders object.


https://reviews.llvm.org/D61779

Files:
  include/lldb/Symbol/FuncUnwinders.h
  source/Symbol/FuncUnwinders.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D61779.198990.patch
Type: text/x-patch
Size: 21490 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20190510/5ea2e965/attachment-0001.bin>


More information about the lldb-commits mailing list