[Lldb-commits] [PATCH] D51176: Restrict the set of plugins used for ProcessMinidump

Leonard Mosescu via lldb-commits lldb-commits at lists.llvm.org
Thu Aug 23 13:36:19 PDT 2018

It's an interesting idea, thanks! I don't object moving code around if
there's a strong case for it, but I'd like to keep the fix small and simple
for now, but it's worth considering if the current minidump loading path
will need more flexibility.

On Thu, Aug 23, 2018 at 1:27 PM, Greg Clayton via Phabricator <
reviews at reviews.llvm.org> wrote:

> clayborg added a comment.
> In https://reviews.llvm.org/D51176#1211433, @jingham wrote:
> > The other option would be to move the code that populates the section
> load list into the mini dump dynamic loader.  That has the benefit of
> keeping this consistent with the other process plugins, but OTOH is just
> moving code around...
> Yes the dynamic loader plug-ins aren't hard to write and the code already
> exists in the ProcessMinidump. Then you would request the plug-in by name
> instead of passing a nullptr as the name in ProcessMinidump::
> GetDynamicLoader().
> Repository:
> https://reviews.llvm.org/D51176
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20180823/24d82df8/attachment.html>

More information about the lldb-commits mailing list