[Lldb-commits] [PATCH] D25832: Minidump plugin: Adding x86_32 register context converter

Pavel Labath via lldb-commits lldb-commits at lists.llvm.org
Fri Oct 28 11:27:39 PDT 2016


labath added inline comments.


================
Comment at: unittests/Process/minidump/MinidumpParserTest.cpp:340
   std::map<uint64_t, uint64_t> reg_values;
 
+  reg_values[lldb_rax_x86_64] = 0x0000000000000000;
----------------
amccarth wrote:
> It seems a shame to remove the `// clang-format off` comment for this section.  The aligned version is easier to read.
I asked Dimitar to remove that. My feeling is that the directive should be reserved for just the extreme cases, where we would end up with a completely unreadable mess without it (like the current register contexts... ugh...). It's not a particularly strong feeling but e.g., there are zero occurrences of this in llvm.


https://reviews.llvm.org/D25832





More information about the lldb-commits mailing list