[Lldb-commits] [PATCH] D19092: Fix Android build after r266267
Enrico Granata via lldb-commits
lldb-commits at lists.llvm.org
Thu Apr 14 11:06:45 PDT 2016
> On Apr 14, 2016, at 10:56 AM, Oleksiy Vyalov via lldb-commits <lldb-commits at lists.llvm.org> wrote:
> ovyalov added a comment.
> In http://reviews.llvm.org/D19092#401450, @jingham wrote:
>> Why is this necessary? stdout is a local variable defined in this scope. Why would the android g++ have problems with this?
>> Anyway, if you have to avoid using stdout as a name, maybe name it std_out as that better reflects its meaning.
> My understanding that NDK toolchain exposes stdout global variable that is caused name collision here.
That seems wrong - if stdout truly is just a global variable, the scoping rules should totally allow me to define a local by the same name
Our (uneducated) guess is that stdout is defined to be a macro which expands to something that is not actually an identifier (which - at a glance - looks like it is not POSIX compliant)
> lldb-commits mailing list
> lldb-commits at lists.llvm.org
📩 egranata@.com ☎️ 27683
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the lldb-commits