[Lldb-commits] [PATCH] D19092: Fix Android build after r266267

Oleksiy Vyalov via lldb-commits lldb-commits at lists.llvm.org
Thu Apr 14 10:56:03 PDT 2016

ovyalov added a comment.

In http://reviews.llvm.org/D19092#401450, @jingham wrote:

> Why is this necessary?  stdout is a local variable defined in this scope.  Why would the android g++ have problems with this?
> Anyway, if you have to avoid using stdout as a name, maybe name it std_out as that better reflects its meaning.

My understanding that NDK toolchain exposes stdout global variable that is caused name collision here.


More information about the lldb-commits mailing list