[Lldb-commits] [PATCH] [TestDataFormatterUnordered] Use patterns to match unordered_<multi>set elements

Chaoren Lin chaorenl at google.com
Wed May 27 17:32:21 PDT 2015


I think it makes sense to update 64 and 65 as well.

On Wed, May 27, 2015 at 5:29 PM, Siva Chandra <sivachandra at google.com>
wrote:

> ================
> Comment at:
> test/functionalities/data-formatter/data-formatter-stl/libcxx/unordered/TestDataFormatterUnordered.py:66
> @@ -65,5 +65,3 @@
>          self.look_for_content_and_continue("mmap",['size=6 {','first =
> 3','second = "this"','first = 2','second = "hello"'])
> -        self.look_for_content_and_continue("iset",['size=5 {','[0] =
> 5','[2] = 3','[3] = 2'])
> -        self.look_for_content_and_continue("sset",['size=5 {','[0] =
> "is"','[1] = "world"','[4] = "hello"'])
> -        self.look_for_content_and_continue("imset",['size=6 {','[0] =
> 3','[1] = 3','[2] = 3','[4] = 2','[5] = 1'])
> -        self.look_for_content_and_continue("smset",['size=5 {','[0] =
> "is"','[1] = "is"','[2] = "world"','[3] = "world"'])
> +        self.look_for_content_and_continue("iset",['size=5 {','\[\d\] =
> 5','\[\d\] = 3','\[\d\] = 2'])
> +        self.look_for_content_and_continue("sset",['size=5 {','\[\d\] =
> "is"','\[\d\] = "world"','\[\d\] = "hello"'])
> ----------------
> chaoren wrote:
> > Could you please add a space after each comma for readability? It'd be
> even nicer if they're all lined up.
> I thought about it. If I add spaces here, would be odd if I do not add for
> lines 64 and 65. However, these lines are beyond the scope of this patch
> IMO.
>
> That said, anything for an LGTM: Should I only update 66-69, or all of
> 64-69?
>
> http://reviews.llvm.org/D10078
>
> EMAIL PREFERENCES
>   http://reviews.llvm.org/settings/panel/emailpreferences/
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-commits/attachments/20150527/3d60cd98/attachment.html>


More information about the lldb-commits mailing list