[Lldb-commits] [PATCH] Fix makefiles to build shared libraries (DLLs) for tests on Windows
Adrian McCarthy
amccarth at google.com
Fri Mar 13 13:53:02 PDT 2015
================
Comment at: test/make/Makefile.rules:378
@@ -375,1 +377,3 @@
#----------------------------------------------------------------------
+$(DYLIB_OBJECTS) : CFLAGS += -DCOMPILING_LLDB_TEST
+
----------------
zturner wrote:
> I think this should be called something like COMPILING_LLDB_TEST_DLL or COMPILING_TEST_DLL. Or anything as long as it has "DLL" in it. Because an EXE is technically an "LLDB Test" also, but it wouldn't have this definition.
Done.
================
Comment at: test/make/Makefile.rules:413
@@ +412,3 @@
+ifeq "$(OS)" "Windows_NT"
+ SEMICOLON = &
+ QUOTE = "
----------------
zturner wrote:
> I'd probably change the name from SEMICOLON to something like JOIN_COMMAND. It's a little confusing to see SEMICOLON = &.
Agreed and done.
================
Comment at: test/make/test_common.h:19
@@ +18,3 @@
+// force include this header file.
+static void *__uncaught_exception() { return nullptr; }
+#endif
----------------
zturner wrote:
> I know you were just copying over my code, but my code was actually wrong here :) __uncaught_exception() should return bool. Can you change this to an inline bool which returns true? https://msdn.microsoft.com/en-us/library/ff770584.aspx?f=255&MSPPError=-2147217396 This is probably only of theoretical value, but we might as well.
I've changed this to #include <eh.h> and rewritten the comment to describe the better understand we arrived at last night.
http://reviews.llvm.org/D8277
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the lldb-commits
mailing list