[Lldb-commits] [PATCH] Fix makefiles to build shared libraries (DLLs) for tests on Windows
Zachary Turner
zturner at google.com
Thu Mar 12 16:16:46 PDT 2015
Looks good, after the remaining changes I'll commit
================
Comment at: test/make/Makefile.rules:378
@@ -375,1 +377,3 @@
#----------------------------------------------------------------------
+$(DYLIB_OBJECTS) : CFLAGS += -DCOMPILING_LLDB_TEST
+
----------------
I think this should be called something like COMPILING_LLDB_TEST_DLL or COMPILING_TEST_DLL. Or anything as long as it has "DLL" in it. Because an EXE is technically an "LLDB Test" also, but it wouldn't have this definition.
================
Comment at: test/make/Makefile.rules:413
@@ +412,3 @@
+ifeq "$(OS)" "Windows_NT"
+ SEMICOLON = &
+ QUOTE = "
----------------
I'd probably change the name from SEMICOLON to something like JOIN_COMMAND. It's a little confusing to see SEMICOLON = &.
================
Comment at: test/make/test_common.h:19
@@ +18,3 @@
+// force include this header file.
+static void *__uncaught_exception() { return nullptr; }
+#endif
----------------
I know you were just copying over my code, but my code was actually wrong here :) __uncaught_exception() should return bool. Can you change this to an inline bool which returns true? https://msdn.microsoft.com/en-us/library/ff770584.aspx?f=255&MSPPError=-2147217396 This is probably only of theoretical value, but we might as well.
http://reviews.llvm.org/D8277
EMAIL PREFERENCES
http://reviews.llvm.org/settings/panel/emailpreferences/
More information about the lldb-commits
mailing list