[Lldb-commits] [PATCH] Renamed ip/dp registers to fip/fdp
Richard Mitton
richard at codersnotes.com
Wed Aug 7 11:43:28 PDT 2013
Exactly, displaying an 'ip' register which is not the instruction
pointer is very unhelpful.
The existing register names are currently different on posix-vs-Darwin
anyway, so there shouldn't be any harm in making the change now. I think
it's "fioff" on Darwin. It uses different display names vs. the internal
variable names.
I agree that it would be nice to make it consistent everywhere.
Personally I'm in favor of it matching the Intel names as closely as
possible. I'm slightly puzzled by how many places in the codebase
(re)define the register sets, it seems like making changes like this may
not be straightforward.
Richard Mitton
richard at codersnotes.com
On 08/07/2013 09:12 AM, Daniel Malea wrote:
> To clarify the original problem this patch addresses (Richard correct me if I'm wrong) the result of a user doing "register read ip" is that they would see the floating point register instead of the instruction pointer.
>
> This change makes the register names on POSIX platforms diverge from the Mac OS X ones.. Specifically, in the darwin plugins, the register in question is still called "ip".
>
> At the very least, this implies we should change TestRegisters.py as well (in its current form, it crashes) but i'm not sure that change is ideal as we'd have to use different names for the same hardware on different platforms.
>
> My gut feeling is we should probably keep register names consistent across platforms... so making this change to the POSIX side might require a corresponding change on the Darwin side -- maybe someone from Apple can chime in on the merits?
>
> http://llvm-reviews.chandlerc.com/D1307
More information about the lldb-commits
mailing list