[Lldb-commits] [PATCH] Renamed ip/dp registers to fip/fdp
daniel.malea at intel.com
Wed Aug 7 09:12:19 PDT 2013
To clarify the original problem this patch addresses (Richard correct me if I'm wrong) the result of a user doing "register read ip" is that they would see the floating point register instead of the instruction pointer.
This change makes the register names on POSIX platforms diverge from the Mac OS X ones.. Specifically, in the darwin plugins, the register in question is still called "ip".
At the very least, this implies we should change TestRegisters.py as well (in its current form, it crashes) but i'm not sure that change is ideal as we'd have to use different names for the same hardware on different platforms.
My gut feeling is we should probably keep register names consistent across platforms... so making this change to the POSIX side might require a corresponding change on the Darwin side -- maybe someone from Apple can chime in on the merits?
More information about the lldb-commits