[libcxx-dev] new format and LIBCXX*_EXECUTOR, LIBCXX_TARGET_INFO

Brian Cain via libcxx-dev libcxx-dev at lists.llvm.org
Mon May 11 13:02:43 PDT 2020

Omitted +libcxx-dev list by accident w/reply.


From: Brian Cain <bcain at codeaurora.org> 
Sent: Monday, May 11, 2020 12:45 PM
To: bcain at codeaurora.org; ldionne at apple.com
Subject: RE: [libcxx-dev] new format and LIBCXX*_EXECUTOR,


Hmm - my mistake, the LIBCXX_TARGET_INFO does still get applied as I expect
but the executor behavior still seems different.  


Instead of LIBCXX_EXECUTOR, I tried setting "self.executor" in the
constructor for the CustomTargetInfo and that was not considered either.
I'll just track this missing executor bit down - probably just needs to be
added to the CxxStandardLibraryTest.




From: libcxx-dev <libcxx-dev-bounces at lists.llvm.org
<mailto:libcxx-dev-bounces at lists.llvm.org> > On Behalf Of Brian Cain via
Sent: Monday, May 11, 2020 12:31 PM
To: libcxx-dev at lists.llvm.org <mailto:libcxx-dev at lists.llvm.org> ;
ldionne at apple.com <mailto:ldionne at apple.com> 
Subject: [libcxx-dev] new format and LIBCXX*_EXECUTOR, LIBCXX_TARGET_INFO




When the switch to the new test format landed on our downstream repo, it
seemed as if the LIBCXX_EXECUTOR and LIBCXX_TARGET_INFO cmake arguments were
being ignored.  I can see a couple of apply/reverts and some fixes to
executor behavior, so I expect that in general the use case for executors is
already considered.  But maybe not being set via cmake?  That said, our
downstream system that takes upstream commits will consider applying them
out-of-order, so I'm not certain I have all of the fixes yet.  I'll continue
to dig deeper, but I just wanted to take a step back and try to understand
if the new format is intended to work like this or if there's another way.


The local config generated by cmake looks like this:



30:config.executor                 = "PrefixExecutor([\"/bin/bash\",


25:config.target_info              =


. and the comment still gets emitted:


note: Using executor: 'PrefixExecutor(["/bin/bash",


. but then I see


: 'EXECUTED AS';  /usr/bin/python /src/llvm-project/libcxx/utils/run.py
--codesign_identity "" --dependencies
andom.shuffle/Output/random_shuffle.cxx1z.pass.cpp.tmp.exe --env
LIBCXX_SRC_ROOT=/src/llvm-project/libcxx --execdir
andom.shuffle/Output/random_shuffle.cxx1z.pass.cpp.tmp.execdir --


If it's just an oversight, I can provide a fix once I figure it out.  I just
wanted to double check whether or not we want these cmake definitions to
work in the future.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/libcxx-dev/attachments/20200511/e816a18b/attachment.html>

More information about the libcxx-dev mailing list