[libcxx-commits] [PATCH] D141812: [libc++] Introduce _LIBCPP_HIDE_FROM_ABI_NAMESPACE_STD

Mark de Wever via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Jan 17 12:14:31 PST 2023


Mordante added inline comments.


================
Comment at: libcxx/test/tools/clang_tidy_checks/hide_from_abi.cpp:16
+bool is_hide_from_abi_namespace(std::string_view str) {
+  return str.size() == strlen("__MAMIPA") && str.starts_with("__");
+}
----------------
philnik wrote:
> Mordante wrote:
> > `__MAMIPA`? 
> major, minor, patch. Do you have a better suggestion?
I would use the magic number 8 and comment describing why it's 8.
I initially read it as MAMI PA, which seems to have no real meaning in libc++.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D141812/new/

https://reviews.llvm.org/D141812



More information about the libcxx-commits mailing list